1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you are going to register on XLNation, please make sure you do not use a proxy server.
    If you use a proxy server your registration will most likely get blocked due to spammers and hackers using proxy servers to hide their real IP address.

    If your using your home or work IP address and have not received your registration email, check your spam folder.
    Dismiss Notice

Cities XXL Game crashes 5-10 minutes in

Discussion in 'Tech Support' started by fcgm12, Jan 9, 2016.

Tags:
  1. fcgm12

    fcgm12 Unskilled Worker

    Joined:
    Sep 26, 2014
    Messages:
    5
    Likes Received:
    0
    I've recently started playing Cities XXL and I have this problem. It happens both with and without mods (the only difference is that I seem to be able to play a little longer without the mods).
    These are the last bits of a couple of the log files:
    Register or to view Spoiler content!
    Register or to view Spoiler content!

    Does anybody have any idea why this is happening & how could I fix it?
    Thanks in advance.
     
  2. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    934
    Likes Received:
    1,218
    Try:
    go to steam/library...right click on cities XXL....choose... properties/local files/verify integrity of game cache

    If that doesn't work (I know it's a pain) try a new complete install and be sure to remove any xxl related files first.
     
    fcgm12 likes this.
  3. fcgm12

    fcgm12 Unskilled Worker

    Joined:
    Sep 26, 2014
    Messages:
    5
    Likes Received:
    0
    Thanks!
    I tried the cache thing but it didn't work.
    I have already done a full re-install and it stayed the same :\

    Apparently it's not the game causing this since I've had a very similar issue playing other games. I'll try updating my drivers and so on. I read somewhere that it might be a problem of small processor or little memory (I have a Dual Core 2.60GHz and only 4Gb of RAM), so yeah...

    Anyway, do you -or anyone- know how to change the settings so that the game autosaves more often? After the cache cleaning it seems to have improved and now I can play for about half an hour; I don't really mind having to re-launch the game every time it crashes, it's just that I lose a lot of the progress since it usually only autosaves once or twice within that time. Is it possible to shorten the times between autosaves? I've tried saving manually but I tend to forget and it's quite a pain in the a**.
     
  4. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    934
    Likes Received:
    1,218
    No way to adjust auto save that I know of. Manual saving is the only way to advance saves.
    Try lowering the "detail display distance" & "traffic density" settings in the options panel.
     
  5. fcgm12

    fcgm12 Unskilled Worker

    Joined:
    Sep 26, 2014
    Messages:
    5
    Likes Received:
    0
    Actually, I've done a throrough clean of my PC (it had been a while since I'd last done it) and now everything works perfectly! The power of dust to screw things up cannot be understated.
    Thank you very much for your help :D

    Now if some mod or something can close this thread or mark it as resolved (or whatever, I'm still a noob)
     

Share This Page