1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. I will no longer be hosting XLNation as of March 1, 2017. Skullz613 will be taking the reigns of the site in early 2017 and XLNation will be moving to a new web hosting service. During that transition there will be an interruption in service of up to two weeks. Skullz613 is now a full administrator of XLNation. Be kind to him.

Cities XXL Map Mod uninstall issue

Discussion in 'Tech Support' started by ronrn, Jun 30, 2015.

  1. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Only one city saved on the Gonaives map.

    Crashes from save/load panel
    after having removed any one of the other 21 maps from the paks/mods/maps folder.

    Put said map back..no crash
     

    Attached Files:

  2. skullz613

    skullz613 Administrator

    Joined:
    Aug 21, 2014
    Messages:
    1,644
    Likes Received:
    1,404
    Theres a lot of errors in that log.
    Removing maps from the mods folder should not cause a crash unless your trying to load a city built on a map you remove.
    Theres errors regarding an airport mod and an enhancement mod. Are you sure you have not taken those mods out of your mods folder? If you have and you have used them in your city, it will cause an error/crash
     
  3. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    I have only one city saved and it is built on the "XLN_Moran_Gonaives_V1" map.
    The only problems I have is the crash after I remove(uninstall) any other maps from the mods folder.

    Don't know if it's relevent, but when I start a new city on a new map there are no recources or road connections. I thought if I cleaned up my map folder and removed the maps not in use, I could fix this problem. That's when the crashing issue started.

    I'm using nearly all of these airport components with no obvious issues.
    XLN_Br41n_Airplane_Livery_Pack_V1.0_4
    XLN_XXL_aitortilla01_Modular_Airport_Pack_v1.2
    XLN_XXL_EI_CargoPlanesVol1a_v1.0
    XLN_XXL_EI_PassengerPlanesVol1_v1.0

    xln_jouse_Airport_Taxiway_Line
    HCB_Airport_asphalt_Square_by_joues_v1.0
    HCB_Airport_Taxiway_components_by_joues_v1.0
    xin_airport_corridor_bridge_joues_v1.0
    xln_jouse_Airport_Apron
    xln_jouse_Airport_Terminal
    xln_new_Apron_joues_v1.0

    zzzzzz_cxxl_enhanced_mod
     
  4. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Log file before any maps were uninstalled.
    Log file after a couple of maps were uninstalled.
     

    Attached Files:

  5. Skater27

    Skater27 Executive

    Joined:
    Aug 30, 2014
    Messages:
    137
    Likes Received:
    14
    Did you clear the cache?
     
  6. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    I've cleared the cache before each restart.
     
  7. Skater27

    Skater27 Executive

    Joined:
    Aug 30, 2014
    Messages:
    137
    Likes Received:
    14
    Check the load save menu to see if the map to be deleted happens to be in there somewhere.
    Otherwise find where the load save data is stored and remove the data for that map.
     
  8. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Backed up that only saved city.
    Did a fresh/complete re-install (took a few tries actually).

    The "mapname_01_slotmap.cxl" files of all of the previously installed maps kept somehow re-appearing in the "solo" folder.
    Manually removed them and everything seems to be working well.
    Re-installed all mods, except for any map mods and again everything seems to be working well.
    Going to attempt to restore the city files now (after installing the corresponding map mod).:unsure:
     
  9. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Success :cool: city restored.
    Just a mystery city with no name(solosaveregion7map25) in the saves panel that appeared with the new game install, could not be deleted cause it had no name.
    Manually removed it from the solo folder.

    Thanks for the feedback.(y)
     
  10. skullz613

    skullz613 Administrator

    Joined:
    Aug 21, 2014
    Messages:
    1,644
    Likes Received:
    1,404
    Glad you got it sorted. I was going to suggest a reinstall after i read the before log due to the errors in it.
     
  11. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Still get these errors in the very first line of every log file.
    Can't decide should I use continue using these airport mods or not.
    I already have tons of these airport components in the city, but no related issues that I can tell....so far.
     

    Attached Files:

  12. ronrn

    ronrn Governor

    Joined:
    Oct 31, 2014
    Messages:
    676
    Likes Received:
    703
    Upon closer observation, I haven't used the said mods, they aren't even showing up in the interface.
    "failed to open pack "....duhhh...sorry for showin my stupidity.
    Anyways, I took them out/uninstalled. Now, to get off my a... and learn how to edit/fix the files.
     
    skullz613 likes this.

Share This Page